menu di navigazione del network

Collegamento ai WS e certificati


(Nico) #62

Sì certo ssl engine è andato in errore. SNI non è supportato in ambiente di test


(Alessio Arrigoni) #63

Ciao, scusa poi come hai risolto il problema del messaggio “Internal error”?
Mi trovo ora io in questa situazione quando invoco il metodo ricevifile usando il codice sopra riportato da Fabio.

Grazie


(Marco Marsala) #64

Controlla tramite https://www.ssllabs.com/ssltest/ che il tuo endpoint ritorni esattamente n. 2 certificati: quello server che ti ha rilasciato lo strumento Gestire il canale e quello della CA. È facile che il webserver ritorni dei certificati ulteriori (per esempio quello di default del webserver), la cosa non creerebbe alcun problema chiamando l’endpoint in un browser con supporto SNI (tutti quelli moderni), ma lo SdI in ambiente di test non lo supporta.


(Marco Marsala) #65

Oppure si può risolvere con un alias o reverse proxy sul webserver (no rewrite).


(Marco Marsala) #66

Devi trustare la CA Entrate nel tuo codice. Anche nel browser ti segnala il sito non sicuro se non installi il certificato della CA nel sistema operativo (o, solo per Firefox, nel suo truststore in quanto non usa quello del S.O.).


(Marco Marsala) #67

Nei messaggi di errore è sempre visualizzato quell’IP al posto del tuo endpoint. Devi considerare comunque i messaggi di errore relativi al tuo endpoint, che in questo caso ha ritornato un errore 500. Controlla i log del webserver per vedere maggiori dettagli.


(Marco Marsala) #68

Devi trustare la root CA Entrate nel tuo codice. Anche nel browser ti segnalerà il sito come non sicuro se non installi il certificato della root CA nel sistema operativo (o, solo per Firefox, nel suo truststore in quanto non usa quello del S.O.).