Problemi nella realizzazione di una app di invio corrispettivi per distributori automatici

Salve a tutti. Sono Dario e sto realizzando per conto di una ditta una app di invio corrispettivi. Ho seguito le linee guida trovate qui Schede - Fatture e corrispettivi - Corrispettivi da Distributori automatici/Vending machine senza porta di comunicazione - Agenzia delle Entrate
Mi trovo di fronte a due scogli da superare il primo è che durante la fase di attivazione il server ADE mi restituisce sempre gli errori:

<Errori>
        <Errore>
            <Codice>00112</Codice>
            <Descrizione>L'elemento TecnicoVerificatore/PIvaSocieta/IdPaese non e' valido</Descrizione>
        </Errore>
        <Errore>
            <Codice>00113</Codice>
            <Descrizione>L'elemento TecnicoVerificatore/PIvaSocieta/IdCodice non e' valido</Descrizione>
        </Errore>
</Errori>

Ho provato ad inserire i codici di tecnici verificatori fiscali abilitati ma comunque il risultato non cambia.
Il secondo scoglio che mi trovo ad affrontare è che nell’invio dei corrispettivi mi da sempre esito:
<Errore><Codice>00000</Codice><Descrizione>XML non conforme al tracciato</Descrizione></Errore>
Ho ricontrollato il tracciato più volte e sembra esattamente quello specificato nell’xsd di ADE.
Ecco il tracciato che mando:

<r:DatiCorrispettivi versione="COR10" xmlns:r="http://ivaservizi.agenziaentrate.gov.it/docs/xsd/corrispettivi/dati/v1.0">
  <Trasmissione>
    <Progressivo>34</Progressivo>
    <Formato>COR10</Formato>
    <Dispositivo>
      <Tipo>DA</Tipo>
      <IdDispositivo>ABC1EFGHI8</IdDispositivo>
      <GeoLocalizzazione>
        <Lat>41.46764</Lat>
        <Long>12.92929</Long>
      </GeoLocalizzazione>
    </Dispositivo>
  </Trasmissione>
  <DataOraRilevazione>2022-11-28T08:33:07</DataOraRilevazione>
  <DatiDA>
    <Periodo>
      <Venduto>1</Venduto>
      <VendutoContante>0</VendutoContante>
      <VendutoNoContante>0</VendutoNoContante>
      <Incassato>1</Incassato>
      <IncassatoRicarica>0</IncassatoRicarica>
      <IncassatoVendita>0</IncassatoVendita>
      <TotaleResoTubiResto>0</TotaleResoTubiResto>
      <TotaleCaricatoTubiResto>0</TotaleCaricatoTubiResto>
      <TotaleResoManualeTubiResto>0</TotaleResoManualeTubiResto>
      <TotaleCaricatoManualeTubiResto>0</TotaleCaricatoManualeTubiResto>
      <DataOraPrelievoPrec>2022-11-20T01:25:24</DataOraPrelievoPrec>
      <ProgressivoPrelievo>33</ProgressivoPrelievo>
    </Periodo>
  </DatiDA>
</r:DatiCorrispettivi>

Se invece provo a mandare il tracciato di un Registratore telematico giustamente mi risponde con un ceriticato NON ATTIVO. Ecco il tracciato corretto:

<r:DatiCorrispettivi xmlns:r="http://ivaservizi.agenziaentrate.gov.it/docs/xsd/corrispettivi/dati/v1.0" versione="COR10">
  <Trasmissione>
    <Progressivo>1268</Progressivo>
    <Formato>COR10</Formato>
  </Trasmissione>
  <DataOraRilevazione>2022-11-28T08:33:07</DataOraRilevazione>
  <DatiRT>
    <Riepilogo>
      <VentilazioneIVA>SI</VentilazioneIVA>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00</ImportoParziale>
    </Riepilogo>
    <Riepilogo>
      <Natura>N4</Natura>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00</ImportoParziale>
    </Riepilogo>
    <Riepilogo>
      <IVA>
        <AliquotaIVA>22.00</AliquotaIVA>
        <Imposta>0.00</Imposta>
      </IVA>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00
      </ImportoParziale>
    </Riepilogo>
    <Riepilogo>
      <IVA>
        <AliquotaIVA>10.00</AliquotaIVA>
        <Imposta>0.00</Imposta>
      </IVA>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00</ImportoParziale>
    </Riepilogo>
    <Riepilogo>
      <IVA>
        <AliquotaIVA>4.00</AliquotaIVA>
        <Imposta>0.00</Imposta>
      </IVA>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00</ImportoParziale>
    </Riepilogo>
    <Riepilogo>
      <IVA>
        <AliquotaIVA>5.00</AliquotaIVA>
        <Imposta>0.00</Imposta>
      </IVA>
      <Ammontare>0.00</Ammontare>
      <ImportoParziale>0.00</ImportoParziale>
    </Riepilogo>
    <Totali>
      <NumeroDocCommerciali>0</NumeroDocCommerciali>
    </Totali>
  </DatiRT>
</r:DatiCorrispettivi>

Vi prego datemi una mano!

Ciao Dario, anche io per conto della mia ditta sto cercando di implementare un servizio di gestione di invio automatico dei corrispettivi, ma come ho scritto qua (Corrispettivi da Distributori Automatici con porta di comunicazione - Errore 500 e altri) sia per la Richiesta certificato dispositivo che per l’attivazione dispositivo ricevo errore 500.
Hai qualche dritta a riguardo (tipo quale e’ l’endpoint)? Premetto che sto usando dati fasulli per testare il codice… Tu come hai fatto?