menu di navigazione del network

[RISOLTO]RicezioneFatture Errore 403 sub 7 random


(Marcello Oberti) #21

Confermo che dopo aver eseguito i comandi netsh indicati da Massimiliano, non si è più verificato il problema.

Grazie e tutti.


(Andrea Lobina) #22

Ciao, anche io ho avuto il problema del 403, alcune fatture passano altre no… ma ho sperimentato che per le notifiche del ws trasmissione fatture l’sdi ritenta più volte sino alla riuscita del recapito. Qualcuno sa se questi tentativi multipli avvengono anche per la ricezione delle fatture? E anche per errori diversi da 403, per esempio nel caso di errore 500 dovuti a falsi p7m che in realtà sono xml normali?


(Bruno) #23

ma scusa non dovrebbe essere disable?

cmq sono io l’unico sfigato a cui ancora i fallimenti random continuano? Il mio win è un 2012R2, ma non credo cambi.

Tra l’altro la cosa stramba è che quando una fattura “non passa”, tutti i tre tentativi per quella non si autenticano, a distanza di ore. Mentre nel frattempo le “altre” vengono ricevute senza errori…


(Bruno) #24

[Risolto] ? Io non mi sento tanto risolto… :frowning:


(Bruno) #25

nelle rules del manyToOneMappings voi cosa state testando?

l’Issuer “CA Agenzia delle Entrate”, il Subject “SDI-XXX” o entrambi?


(Matteo) #26

Di norma andrebbe Enable ma alcuni di noi (che si sono accreditati prima di Ottobre hanno dei certificati client forniti da SDI che sono scaduti… SDI ha detto che non è necessario rigenerare i certificati ma se lasci Enable quella opzione può dare adito all’errore 403…
Se la fattura non passa tutti e 3 i tentativi finisce nel cassetto fiscale del destinatario (nel portale ivaservizi… Fatture FE messe a Disposizione nella sezione Consultazione… Non viene più tentato la consegna all’intermediario e a chi ha inviato la fattura viene generata una notifica di mancata consegna.

I consigli che ti posso dare sono quelli già scritti prima:
verifyclientcertrevocation= Disable (se hai il certificato scaduto)
clientcertnegotiation=Enable
e verificare di avese solo il certificato di produzione nella root dei certificati attendibili nella User.
Prova a riconfigurare il certificato su IIS come ti ha indicato Massimiliano.

Noi non abbiamo un flusso di ricezione altissimo (circa 150 Fatture al giorno e 150 notifiche) e da 15 giorni non ho più avuto l’errore 403.7 prima delle modifiche avevo il 30% di errori 403.7…


(***) #27

Buonasera Massimiliano, anche io ho questi problemi e ho letto le tue indicazioni, volevo gentilmente chiederti se la procedura che hai indicati deve essere eseguita per ognuno dei binding che mi mostra il comando “show”?


(Antonio) #28

Grazie mille!! forse forse… con imprecazioni incluse :-), la tua è la soluzione giusta!


(***) #29

Ho utilizzato anche io i tuoi suggerimenti ho solamente usato il comando “Netsh http Update sslcert” per la sola ipport 0.0.0.0:443 ed ho modificato solamente il parametro clientcertnegotiation in Enable.
da quel momento tutte le chiamate POST arrivano 200 0 0


(Massimiliano) #30

Io ho abilitato oneToOneCetrificateMappingsEnable ed ho associato le stringhe dei certificati ad un utente locale usato solo dallo SDI, in questo modo se un certificato scade basta aggiungere una nuova riga; per esempio quando era scaduto il certificato di test. In questo modo sulla stessa macchina ho sia l’ambiente di produzione che quello di sperimentazione (avevo richiesto direttamente abilitazione all’agenzia delle entrate - si trova documentazione sul sito per richiesta - per poter continuare ad usare l’ambiente di test nonostante il canale sia passato in produzione)


(Michele ) #31

Dopo aver fatto queste modifiche le fatture che prima non arrivavano ora arrivano triple.
Il supporto dice che è colpa del mio canale… dicono che ricevono un errore java (per cui la mandano tre volte) mentre invece il mio canale riceve le fatture regolarmente. Inoltre ricevo un certo numero di fatture ed è tutto regolare. Immagino che quelche server da cui inviano le fartture abbia qualche grosso problema.