menu di navigazione del network

SDICOOP - Errore 403.64

Buongiorno,
a seguito dell’aggiornamento dei certificati mi sono trovato in una situazione in cui per evitare confusione ho proceduto ad effettuare una nuova richiesta di certificati. Lavoro su IIS su una macchina virtuale Azure.

Quello che ho fatto, seguendo la strada che avevo fatto per i primi certificati, è stato:

  • Generazione dei .pfx partendo dai certificati .pem client e server + SistemaInterscambioFatturaPA + CAEntrate_prod.der
  • Importazione dei pfx nello store Personal sia della macchina che dell’utente
  • Importazione nello store “Trusted Root Certificate Authorities” della macchina dei CAEntrate_prod.der
  • Importazione nello store “Trusted People” della macchina dei CAEntrate_prod.der
  • Rimozione CLR dal binding IIS

Su IIS ho una configurazione OneToOne e OneToMany, l’application pool ha come identity l’utente della macchina che quindi ha accesso ai certificati. Inoltre ho impostato nel binding della webapplication il certificato SDI.

Il problema che riscontro dai log iis sono sporadici e in ricezione fatture dall’SDI, quindi alcune fatture entrano, altre danno l’errore 403 con substatus 64: The specified network name is no longer available.
Qualcuno ha già riscontrato questo problema e può aiutarmi a risolverlo? Trovo strano che lo dia solo su alcune chiamate di ricezione fatture e non tutte.

Grazie!

Non se sia anche il tuo caso, ma molti di noi hanno risolto questo tipo d’errore seguendo questa guida:

Io ho risolto così:
netsh http show sslcert
e ottieni
SSL Certificate bindings:

IP:port                      : 0.0.0.0:443
Certificate Hash             : <cert_hash>
Application ID               : {<app_id>}
Certificate Store Name       : My
Verify Client Certificate Revocation : Enabled
Verify Revocation Using Cached Client Certificate Only : Disabled
Usage Check                  : Enabled
Revocation Freshness Time    : 0
URL Retrieval Timeout        : 0
Ctl Identifier               : (null)
Ctl Store Name               : (null)
DS Mapper Usage              : Disabled
Negotiate Client Certificate : Disabled

poi esegui il delete
netsh http delete sslcert 0.0.0.0:443

ed infine fai l’add
netsh http add sslcert 0.0.0.0:443 <cert_hash> {<app_id> } clientcertnegotiation=enable verifyclientcertrevocation=disable

Ti consiglio, rispetto ad altre guide che si trovano in rete, di aggiungere, come sopra, anche
verifyclientcertrevocation=disable
altrimenti dopo un po’ va di nuovo in errore 403.16

Al posto di 0.0.0.0:443 ovviamente indica il tuo ip per il servizio sdi.

Spero ti sia di aiuto.