menu di navigazione del network

SPID e PHP


(Lello) #1

Buonasera a tutti,
colgo l’occasione per salutare @umbros , incontrato al raduno degli RTD a Bologna.
Ho trovato l’sdk per PHP sviluppato da Michele D’Amico https://github.com/italia/spid-php e volevo chiedere se fosse indispensabile l’utilizzo di PHP 7. Attualmente uso CentOS 7 come sistema operativo per un webserver e la versione più alta di PHP che raggiungo è la 5.x.
Effettuare un aggiornamento così importante su una macchina che ospita una piattaforma di candidatura operativa h24, mi sembra un azzardo (a dir poco).
Ho creato un ambiente di test, clone della produzione, però vorrei sapere se è possibile evitare l’aggiornamento.
Chiedo anche se fosse possibile consultare una guida passo passo sulla configurazione perchè non ho molta dimestichezza con il composer. Ho sempre usato il vecchio require_once per i vari sdk.