menu di navigazione del network

Software CIE 1.3.1 per UBUNTU 20.04

Ho installato il lettore correttamente che mi legge i dati CIE con comando linux nfc-list ma il software CIE sente la carta CIE ma non conclude l’abbinamento con notifica “Errore inaspettato durante la comunicazione con la smart card”

C’è una versione superiore alla 1.3.1 per linux ? Potrebbe risolvere il bug…

Grazie

1 Mi Piace

ma qualcuno ha utilizzato la CIE con qualche versione anche precedente di UBUNTU ?

Prima della 20.04 avevo provato con la 18.10 di Ubuntu … stessi problemi… spero nella prossima versione di CIE ID

Buongiorno @enzonic,

dalla descrizione dell’errore sembrerebbe un problema di comunicazione del lettore, ma non dipendente dal Software CIE.

qualche verifica:

  1. Di che modello di lettore si tratta?
  2. I driver sono correttamente installati?
  3. Ha utilizzato con successo il medesimo lettore con la CIE su altri sistemi operativi?
  4. Ha modo di effettuare una prova con un altro lettore, magari di un suo conoscente?

Ci faccia sapere.
Grazie.

Buongiorno, La ringrazio per la risposta… Le fornisco le informazioni richieste

Il modello è ACR122U della ACS (Advanced Card System Ltd.), ho installato i driver indicati dalla ACS e non ho rilevato errori o anomalie particolari.
Non ho ancora provato il lettore su altri OS… per ora non ho altri lettori (ACR122U è una fornitura acquistata dal Comune di Cinisello Balsamo), spero di riuscire a provare con un altro lettore e provare il mio su altro sistema.

Intanto, per completezza di informazione e capire dove intervenire, sperando possano essere utili per la risoluzione del problema, Le mostro da linea di comando linux i risultati di nfc-list che rileva il lettore e quando si avvicina la CIE vengono fornite delle info (come da screeshot) ma CIE ID dà ‘errore inaspettato’.
Cosa mi consiglia ?

Grazie

Purtroppo, come anche si evince da innumerevoli altri thread su questo forum, il lettore ACR122U è stato e continua ad essere fonte di innumerevoli problemi con la CIE, a causa della presenza sul mercato di molti modelli con un firmware obsoleto che non sono in grado di gestire correttamente la comunicazione con il chip della CIE necessaria ad una autenticazione forte.

La capacità di leggere l’ATS è purtroppo una verifica non significativa di corretto funzionamento del lettore con la carta ai fini dell’autenticazione.

Ha modo di provare il lettore con una postazione Windows?

Ho appena provato con Windows… il lettore funziona, CIE ID per windows abbina correttamente e fornisce il certificato . Ho testato l’autenticazione con fascicolo sanitario lombardia (con Chrome) seppure con una anomalia che si ripete ad ogni tentativo (screenshot allegato) poi provando a tornare indietro da browser, alla fine si viene rediretti correttamente nel proprio fascicolo personale.

A questo punto, visto che non ho riscontri di altri che hanno installato lettore in oggetto e CIE ID su Ubuntu Le chiedo se mi consiglia altro lettore che qualcuno ha già testato su linux ?

Grazie

Funziona con Ubuntu 20.04.2 LTS
Scaricato https://www.acs.com.hk/download-driver-unified/12030/ACS-Unified-Driver-Lnx-Mac-118-P.zip
Quindi:

  1. Login as root.

  2. Enter the following commands to unpack the driver source code.

tar -jxvf acsccid-x.y.z.tar.bz2

cd acsccid-x.y.z

  1. Enter the following commands to install the driver.

./configure

make

make install

aggiungere pn533_usb in /etc/modprobe.d/blacklist-libnfc.conf
+
reboot