menu di navigazione del network

Testenv , esempio in spid-php-lib e "not logged in!"

Buongiorno a tutti,
sto implementando un’autenticazione SPID per un’associazione mia cliente tramite l’SDK php utilizzando per le prove spid-testenv2-master. Sono riuscito a far funzionare l’applicazione di prova messa a disposizione sull’SDK php e ad adattarla per integrarla nella piattaforma dell’associazione e a testarla sia con spid-testenv2-master che con idp.spid.gov.it . Ho però 2 problemi:

  1. a fronte di login validi (con entrambi gli ambienti di test) , la prima volta mi ritorna sempre “Not logged in!” e quindi devo ritentare un nuovo login e dopo di che tutto funziona correttamente. Questo comportamento l’ho riscontrato anche sull’applicazione di esempio dell’SDK php.
  2. il secondo problema strano è che quando l’IdP restituisce il controllo all’applicazione dell’SP tramite l’acs gli eventuali cookies settati prima della chiamata della login non vengono letti all’interno dell’acs.

Spero che la descrizione del problema sia stata abbastanza chiara, nel caso sono a disposizione per delucidazioni. Spero che qualcuno possa fornirmi qualche indicazione di cosa controllare.

Grazie per l’attenzione

Benvenuto nel forum!

Il problema si verifica anche usando l’applicazione di esempio di spid-php-lib senza modifiche, da sola? Oppure si presenta solo dopo l’adattamento con la vostra piattaforma?

Grazie per il benvenuto!

Si, si presenta anche nell’applicazione di esempio senza modifiche. Pensavo si trattasse di un problema del mio testenv, ma poi ho visto che anche con idp.spid.gov.it ha lo stesso comportamento.