menu di navigazione del network

Totem - Accesso ai servizi tramite CIE

Vorremmo rendere disponibili al pubblico alcuni servizi comunali da utilizzare presso alcuni totem. Il problema è che per l’accesso a tali servizi vorremmo utilizzare (anche) l’autenticazione tramite CIE, che richiederebbe l’installazione della CIE sul totem ogni volta per ogni cittadino. Abbastanza scomodo per il cittadino e con il rischio di violazioni della privacy. Sono state fatte già esperienze di questo tipo CIE/Totem? Chiedo aiuto, gentilmente, a @IPZS-CIE

2 Likes

Ciao Edoardo, per svincolarti dal sistema operativi, installazione ecc… puoi accedere alla cie tramite apdu. Nella cie, ci sono due app, una delle due ti permette di accedere al certificato di strong authentication. E’ una strada complessa però ti permette di svincolarti dai driver della carta.

Saluti
Giuseppe Locorotondo

Ciao @Giuseppe_Locorotondo, anzitutto grazie per la risposta. In base alle tue indicazioni ho pensato di provare il codice messo a disposizione nella sezione SDK di https://developers.italia.it/it/cie/

Purtroppo, in debug quando cerco di leggere i dati della CIE mi dà errore in entrambe le soluzioni:

Ho provato sia con l’autenticazione PACE tramite CAN, sia con l’autenticazione BAC(MRZbirthDate, expiryDate, passNumber) senza successo.

Ti risulta che funzioni questo sdk messo a disposizione ? Forse è diventato obsoleto?

@IPZS-CIE sto utilizzando un lettore che con l’ultima versione del Middleware funziona bene, in quanto permette di abilitare/installare la CIE sul pc senza problemi. E’ possibile, invece, che i problemi che sto avendo in debug ( cie-mrtd-dotnet-sdk, cie-mrtd-example-app ) possano dipendere dal lettore ? Grazie

io partendo da quel codice, e con la documentazione tecnica riesco a fare tutto, leggo anche la foto, riesco anche ad autenticarmi attraverso apdu, senza passare da nessuna libreria di terze parti.
Uso sia Bac che Pace con successo. Leggo anche il passaporto via Nfc.

Forse hai qualche problema con il lettore?

Prova a questo punto a fare autenticazione usando le librerie di alto livello, per vedere se funziona lettore e cie. Se tutto funziona puoi procedere con sdk.

Ciao Giuseppe