menu di navigazione del network

Validazione edas con xsd

Buongiorno,
la validazione del edas.xml dà questo messaggio:

  • Cvc-complex-type.2.4.a: Invalid Content Was Found Starting With Element ‘AttributiMessaggio’. One Of ‘{“http://das.dogane.finanze.it”:attributiMessaggio}’ Is Expected., Line ‘2’, Column ‘22’.

Contenuto dell’edas:

<?xml version="1.0" encoding="UTF-8"?>

<ns3:DE815 xmlns:ns2=“http://www.w3.org/2001/XMLSchema” xmlns:ns3=“http://das.dogane.finanze.it”>

DE815
ITXXXXXXXXXX
2020M0123000
1
0

Io non riesco a capire qual è il problema.
Grazie per l’aiuto
Francesco

Il contenuto che hai copiato non è un XML. Dovrebbe essere qualcosa del tipo (lascia perdere l’header che può essere codificato in vari modi):

<?xml version="1.0" encoding="UTF-8"?> DE815 ITXXXXXXXXXX

)ecc.)

Avevo copiato cinque o sei righe di xml a cui sono stati tolti i tag automaticamente lasciando solo il text. Non so come riportare un testo xml senza che venga interpretato dal sito.
La difficoltà che si ha nel debug del file xml è che i progettisti della AdD dovevano mettere a disposizione emulatori (endpoint) a più livelli senza controllo di firma per effettuare al primo livello il controllo SOAP, quindi al secondo quello xsd o formato ed infine il livello del controllo di contenuto. Una software house per fare il debug deve richiedere al cliente i dati sensibili come certificati SSL e certificati di firma per svolgere il lavoro di debug in azienda e questo ha reso tutto difficile. Ma ci sono altre considerazioni che non faccio che che denunciano altre manchevolezze. Grazie della risposta, ho superato il problema oggetto di questo post.