ACR122 ed errore "La Smart Card non è in grado di eseguire l'operazione richiesta o...smart card diversa"

Buona sera,
Sono un possessore di un Lettore ACS ACR122 di cui ho letto le varie problematiche.
Ho provato in tutti i modi ma non riesco ad utilizzarlo.
Sequenza di installazione in Windows:

  1. Driver 4.2.8.0 - riavvio
  2. CIE Middleware: 1.4.3-4 riavvio
  3. Associazione CIE - Ok
  4. Accesso al sito mediante scelta - accesso via computer - certificato appare, lo seleziono Ok

Ma quando vengo al dunque sia su sito Agenzia Entrate che altrove, l’errore é sempre lo stesso dopo il controllo della Smart in Corso… appare:
“La smart card non è in grado di eseguire l’operazione richiesta oppure l’operazione richiede una smart card diversa.”

Ho provato con: Brave, Chrome ed Edge, il tutto in Windows.
Ho raccolto le seguenti schermate dando un’occhiata agli altri thread:




4-Smart_APDU_Ugo_Chirico

Qualche suggerimento su come procedere, per favore? Sto impazzendo! Grazie.
@IPZS-CIE
@ettoremazza

Salve, aiutarla a distanza è davvero complicato.
Procederei per passi:
Intanto, da cellulare funziona ? Riesce ad accedere ?
Ha la possibilità di cambiare PC (quello di un amico o di un collega ?)
Ha qualche antivirus installato ?

Grazie per l’intervento, @ettoremazza .
Speravo che con tutti i dettagli pubblicati potesse essere più facile specie per @IPZS-CIE che in passato - ho visto - ha risposto ad altri utenti con il medesimo lettore (ma a quel tempo la versione del middleware era magari acerba).

Non uso smartphone o app per autenticarmi con la CIE La CIE sicuramente funziona perchè è stata usata su altro computer con altro lettore:

5 - smart card pronta

Per rispondere alla sua domanda, nel PC attuale con il lettore ACR122. di cui alle schermate del primo post, non ci sono antivirus di terze parti installati, nè Kaspersky e nè Eset, semplicemente Windows Defender.
@IPZS-CIE: Tra l’altro si vede chiaramente dall’ACS Monitor che la smart card risulta riconosciuta: “Connected”. Diversamente il card status sarebbe “Removed”.
Il QuickView mostra ulteriori dettagli e nella schermata APDU si vede anche il firmware .U.2.

Non capisco dove possa essere il problema ed il messaggio è criptico: se è registrata dal CIE Middlewate ultima versione come fa a non essere in grado di eseguire l’operazione di autenticazione ed addirittura se aspetta di autenticarne una diversa?

@Edoardo_Savini, @m.cristiano , @Andrea_Tironi1, @UgoChirico
@Tazio28, @fede_g @Agos1969

P.S. @emmedi Ho già appoggiato la CIE all’ACR122U interponendo uno spessore, rotolino di scotch. E funziona nell’altro PC ma non su questo.

Da quello che ha scritto deduco che il problema ce l’ha solo con il suo PC, tutte le altre componenti su un altro PC funzionano correttamente (lettore, CIE, software).
A questo punto è impossibile aiutarla, sul PC ci sono troppe variabili impossibili da controllare a distanza.

Grazie per la risposta ma non capisco: i controlli dovrebbero servire per diminuire le variabili e non per compromettere la ricerca. Quel che sappiamo è che il lettore, la CIE non sono difettosi, cosa non scontata.
Ed allora? Tutti gli altri utenti che hanno problemi con i lettori e la loro CIE si sono trovati anche nel passatoin situazioni simili con questo ACR122.
E non hanno postato tutti i dettagli che invece mi sono premurato di fornire.

@IPZS-CIE: nessuna idea, per favore?

Intanto prova ad accedere nelle impostazioni del PC e verificare nella gestione dei dispositivi se il lettore risulta opportunamente configurato.
A presto
Agos

1 Mi Piace

@Agos1969 Agos1969
Grazie per il tuo intervento.
Questo è quanto si vede dal PC in cui il lettore non gestisce la CIE (di cui alle immagini sopra del primo post e relativo errore come da titolo):

Per la cronaca -invece- questo è il PC in cui il lettore ACR122 funziona con la medesima CIE: si vede come risulti sconosciuto mentre in realtà tutto funziona perfettamente. Si è già visto in altri utenti:

Come vorrei che anche nel primo PC venisse mostrato paradossalmente smart card sconosciuta ma tutto funzionasse… purtroppo accade il contrario.
A presto e grazie.
@IPZS-CIE

Prova, sul pc che mostra difficoltà, a disistallare il dispositivo ed ad aggiungere manualmente seguendo il percorso : start, impostazioni, dispositivi, aggiungi dispositivo…

A presto
Agos

@Agos1969
Grazie per la risposta.

  1. Ho disinstallato il lettore.
    Poi con aggiungi dispositivo mi ha trovato un dispositivo ‘sconosciuto’ … non ho idea cosa abbia installato perchè poi la procedura è terminata da sola. A quel punto nella Gestione Dispositivi non c’era nessuno dei due status sopra illustrati: nè l’ACR122 e nè Smart Card sconosciuta. E del resto posando sopra al lettore la CIE non reagiva con alcun beep; semplicemente non esisteva.

  2. A questo punto, ho disconnesso il lettore ACR122 dalla porta USB e l’ho reinserito e si è re-installato da solo apparendo in Gestione Dispositivi.
    Ho dunque provato a loggarmi appoggiando la CIE ma il risultato è il medesimo errore come da titolo del thread.

3 Allora ho disinstallato ancora il lettore, e poi selezionato Rileva modifiche hardware. Il risultato purtroppo è lo stesso: il browser chiede sì di selezionare il certificato come sempre, avviene il controllo smart card (“controllo dello stato in corso…”) ma tutto finisce con il solito "La smart card non è in grado di eseguire l’operazione richiesta oppure l’operazione richiede una smart card diversa’.
In tutte queste situazioni in cui l’ACR122U è stato riconosciuto da Windows, aprendo l’ACS Reader Monitor mostra lo status di presenza (‘Connected’) sopra illustrato.

Grazie, a presto.

P.S. @IPZS-CIE : abilitando il log a livello ‘Error’ o ‘Debug’ del CIE Middleware può servire a qualcosa?

@erik1
Ritengo che il problema non sia legato al software CIE ma bensì al tuo computer che in qualche modo blindi l’accesso mediante lettore, ti chiedo un’altra informazione i due computer hanno gli stessi sistemi operativi?

A presto
Agos

@Agos1969

Cosa significherebbe che blinda l’accesso mediante lettore?
Il due computer hanno due Windows diversi: quel che non funziona ora è Windows Pro 8.1 ed è quello con il lettore elencato in Gestione Dispositivi .

@IPZS-CIE Preciso che il 31/01/2023, come da Timestamp della prima installazione del driver visualizzata nell’immagine più sopra, il lettore funzionava benissimo. Poi ho avuto diverse difficoltà con la CIE nell’accedere ad un paio di siti con errori di diverso tipo e così quando ho scoperto che in Gestione Dispositivi appariva una dicitura Smart card sconosciuta, ho avuto l’insana idea di reinstallare i driver: quel punto il lettore è apparso in Gestione Dispositivi e comunque non ha funzionato ugualmente da quel 13 aprile.