menu di navigazione del network

Lettura Cie con smart card


(isabella) #21

Ciao German Iglesias,
grazie per l’info. personalmente ho installato il middleware cie, ed eseguito la prova come indicato da IPZS-CIE all’inizio della discussione ignorando l’errore SmartCard Sconosciuta in gestione dispositivi e sono riuscita ad autenticarmi al sito https://accessosicuro.rete.toscana.it
In poche parole, pare che il lettore funzioni correttamente, nonostante la segnalazione, non certo bella da vedere!
chiederò senz’altro ulteriori consigli all’indirizzo cie.cittadini@interno.it per risolvere il problema.


(Istituto Poligrafico e Zecca dello Stato) #22

Buonasera Isabella,

se alludi alla voce “Smart card sconosciuta” nella gestione dispositivi, come mostrato nella figura in allegato, ti confermiamo che è un comportamento previsto, dal momento che l’interfacciamento della CIE per l’utilizzo all’interno del sistema operativo come dispositivo di accesso sicuro ai servizi in rete è tutto demandato al Software CIE.

Ne è la prova che sei riuscita ad accedere tranquillamente ad accessosicuro.rete.toscana.it.

@Fabio_Ottavi saprà aggiungere maggiori dettagli.
Grazie molte, in ogni caso, per il feedback.


(Fabio Ottavi) #23

Buonasera,
confermo che i dispositivi smart card su windows 7 sono indipendenti dal funzionamento delle applicazioni, quindi l’errore può essere tranquillamente ignorato.
Però di solito il corretto riconoscimento del dispositivo è indice della corretta installazione del software di gestione della smart card, quindi vorrei fare qualche domanda a @isa e @german_iglesias che hanno incontrato questo comportamento.
L’accesso al sito della regione Toscana, che come leggo dai precedenti post è stato effettuato correttamente, su che browser è stato fatto? Chrome, Internet Explorer o Firefox?
La CIE appoggiata sul lettore era abilitata (inserendo tutte le 8 cifre del PIN) quando è stato visualizzato l’errore in gestione dispositivi?
E’ stato riavviato il sistema dopo l’installazione del middleware?
Grazie per il supporto, buona serata


(isabella) #24

Salve Fabio,
grazie a IPZS-CIE ed a te per le delucidazioni.
La procedura che ho utilizzato è stata la seguente:

  1. collegato lettore (ACR122 Smart Card Reader riconosciuto correttamente tra i dispositivi)
  2. eseguito installazione middleware
  3. riavviato pc
  4. appoggiata CIE sul lettore (compare errore Smart card in gestione dispositivi)
  5. con Chrome, digitato sito https://accessosicuro.rete.toscana.it e si è avviata la procedura di abilitazione CIE ad 8 cifre
  6. riprovato ad accedere al sito con autenticazione pin 4 cifre. tutto ok!
    l’accesso con I.E.11 richiede il pin 4 cifre, ma restituisce errore “Non riesco a visualizzare questa pagina … crittografia RC4 non supportato”.
    con Firefox, l’accesso avviene regolarmente (caricando il modulo ciepki.dll in gestione dispositivi)
    volevo chiedere gentilmente un’altra informazione: quando eseguo ‘verifica aggiornamenti’ middlweare, sempre in windows 7, compare ‘Errore nella comunicazione con il server’, c’è un motivo specifico?
    grazie e buona serata a tutti voi
    isa

(Giuseppe) #25

Buonasera,
Sto cercando di registrami a SPID con un lettore di Smart card modello Acr122u-a9, una volta effettuata l’installzione dei driver del dispositivo e del programma Middleware CIE su windows lancio il procedimento di sblocco pin come primo accesso ma non mi si apre l’applicazione. Ho provato anche a lanciare l’applicazione senza appoggiare la cie 3.0 e poi successivamente appoggiandola sul lettore e in questo caso mi dice “impossibile trovare una cie nei lettori di Smart card “ qualcuno può darmi una mano dato che con questo lettore ho letto che si riesce a leggere e sbloccare la cie ??? Grazie mille


(Giovanni Marani) #26

Ho esattamente lo stesso problema.
ho provato su tutti browser, ho installato i driver aggiornati e seguito alla lettera le istruzioni per il primo utilizzo.
Purtroppo sembra che il lettore non riesca a dialogare con il browser e/o con il software middleware.

Ho installato il programma ACS Reader monitor, software della casa produttrice del device: quando appoggio la carta sul lettore il programma la riconosce e legge correttamente.

Avrei bisogno di aiuto, non ci salto fuori!


(Istituto Poligrafico e Zecca dello Stato) #27

Buonasera Giuseppe,

hai effettuato la procedura di Abilitazione CIE prima di registrarti a SPID? Perchè stai sbloccando il PIN?

Dopo la prima installazione del middleware CIE, appena attivato Chrome dovresti ricevere un avviso che ti invita ad abilitare la CIE sulla postazione.

Se non è così, dobbiamo fare delle verifiche insieme, ti chiediamo di inviare una mail a cie.cittadini@interno.it specificando un recapito telefonico a cui essere contattato per prove congiunte. Grazie.


(Istituto Poligrafico e Zecca dello Stato) #28

Buon pomeriggio Giovanni, possiamo chiederti dettagli sul sistema operativo utilizzato, sui passi che hai compiuto e quale browser stai usando?
Grazie.


(Giovanni Marani) #29

buonasera e grazie per la risposta.
Perdonatemi se sarò un po’ prolisso.

Sistema Operativo Windows 10
Modello lettore ACR122U-A9

i passi sono stati:

  1. installazione lettore smart card con i driver del produttore (ACS_Unified_Driver_MSI_Win_4280_P)
  2. installazione software middleware dal sito del ministero (CIE-Middleware-v1.0RC2.exe)
  3. riavvio
  4. connessione lettore smart card, CIE appoggiata sul lettore, il sistema risponde correttamente. In gestione dispositivi vedo il lettore e la CIE
  5. Con Chrome accesso al sito https://accessosicuro.rete.toscana.it e tentativo di accesso con CIE. Mi risponde che “qualcosa è andato storto”.
  6. dopo attenta lettura di questa pagina https://cie30-middleware.readthedocs.io/it/latest/index.html ho tentato con Edge, ed Explorer, con il medesimo esito
  7. ho wuindi provato con Firefox seguendo alla lettera le istruzioni, ma nonostante la CIE sia sul lettore e il lettore la legga (il software del produttore di cui vi parlavo monitora costantemente questo espetto), ottengo questo:

ormai sono due settimane che provo, senza esito, tutte le procedure suggerite.

Dimenticavo, ho anche provato su un altro Windows 10 e su un Windows 8 (tutti e tre i sistemi operativi sono su Lenovo), con identico risultato.
Concludo confermando che sono stato sul sito del ministero per verificare che la mia CIE non fosse danneggiata o difettosa (https://www.cartaidentita.interno.gov.it/verifica-cie/) ma l’esito è che la carta è correttamente funzionante.

non so più cosa tentare.


(Giuseppe) #30

Buonasera grazie per la risposta comunque confermo alla lettera lo stesso identico problema che ha descritto il signor Giovanni con le stesse identiche procedure. In aggiunta ho provato anche con un Mac Book. Ma niente da fare non so più che tentativi effettuare. Attendo Una vostra risposta.
Distinti Saluti


(Istituto Poligrafico e Zecca dello Stato) #31

Buonasera Giovanni,

le schermate che hai inviato sono state in realtà molto utili per consentirci di diagnosticare il problema. Sembrerebbe che il lettore da te utilizzato legga la carta in un modo che non è considerato standard fornendo al sistema operativo un identificativo che per il Middleware CIE è sconosciuto.

Nel dettaglio, l’informazione che non è fornita in modo standard è l’ATR (Answer to reset) e lo si può evincere da questa schermata che tu stesso ci hai fornito (la prima).

Normalmente la cosa si risolve installando un driver di una diversa versione. Ad ogni modo per gestire questo tipo di casistica temiamo che sia necessario un adeguamento al middleware CIE.

Abbiamo ragione di credere che sia lo stesso problema rappresentato da @Giuseppe94 che ha lo stesso lettore tuo.

Tra l’altro, la funzionalità di Verifica CIE sul sito del Ministero dell’Interno non ha nulla a che vedere con quanto da te rappresentato.

Cercheremo di attivarci per approfondire il comportamento ed apportare i necessari adeguamenti il prima possibile. Grazie per il momento della collaborazione.


(Giovanni Marani) #32

Grazie a voi per la cortese e sollecita risposta.
In attesa di una nuova Release del Middleware CIE che tenga conto di questa “anomalia”, dato che conoscete il modello del mio lettore, sapreste per cortesia suggerirmi quali driver poter installare in sostituzione di quelli attualmente in uso (frutto dell’esperienza maturata nel vostro dialogo costante con gli utenti), così da poter utilizzare la carta?


(marco) #33

Salve, sono allo stesso punto del Sig. Giovanni, speriamo presto in un aggiornamente dei driver.
Saluti


(Giovanni Marani) #34

Buonasera,
mi rendo conto di non trovarmi nel forum di un customer care :slight_smile:

…ma…io la carta d’identità la devo usare per davvero, ci sono novità in merito al quesito posto da me, dal Sig. Marco e dal Sig. Giuseppe?

Grazie


(marco) #35

Per quel che può servire, ho eseguito le stesse prove su 3 pc differenti, con lettore acr122u-a9, usando i driver di win che quelli del produttore e poi installando i driver cie versione 1.0rc2, vedo il lettore, vedo la smartcard come sconosciuta ed ho lo stesso ATR del sig. Giovanni.

Siamo in attesa di un driver nuovo, disposto anche a far da beta tester purchè riesca a leggere la cie3.0

Grazie


(Istituto Poligrafico e Zecca dello Stato) #36

Stiamo approfondendo la questione, sospettiamo che il tutto possa dipendere da versioni differenti del firmware di questo lettore che sono in circolazione. Ne è la prova il fatto in taluni casi ha funzionato, come riportato nel thread.
Non abbiamo però ancora la certezza di ciò e non sappiamo ancora tanto più se tale firmware sia in caso aggiornabile.
Vi teniamo aggiornati e cercheremo di fare più velocemente possibile.


(Istituto Poligrafico e Zecca dello Stato) #37

@marcolino @giovanni_marani @Giuseppe94

Abbiamo rilasciato la beta 1.1 del middleware Windows su

che dovrebbe risolvere il problema della lettura dell’ATR con il lettore ACR122.
Possiamo chiedere la vostra collaborazione per un test?

Vi suggeriamo, a tal proposito, di:

  1. Disinstallare il vecchio CIE middleware 1.0
  2. Riavviare per precauzione il PC
  3. Installare il nuovo pacchetto
  4. Poggiare la carta sul lettore
  5. Aprire il browser, digitare “iris.rete.toscana.it” e verificare che parta la procedura di Abilitazione della CIE sul vostro PC.
  6. Immettere il PIN e completare l’abilitazione
  7. Effettuare un accesso al sito della regione Toscana, cliccando su “Accedi”, quindi su “Entra con CIE” ed inserendo quando richiesto la seconda metà del PIN.

Se possibile, provate anche a cambiare il PIN e a sbloccarlo usando il PUK.
Grazie in anticipo per tutto l’aiuto che potrete fornirci.


(Giovanni Marani) #38

Grazie a voi, provo subito.


(Giovanni Marani) #39

Buona Domenica,
ho effettuato i passaggi 1, 2, 3, 4, 5 come suggerito, ma non appare nulla che sia riferibile alla procedura di abilitazione della CIE.

https://iris.rete.toscana.it/public/ = non parte la procedura
sono andato su “accesso autenticato” = non parte la procedura
ho cliccato “entra con CIE” = “Qualcosa è andato storto”

In compenso se utilizzo direttamente il Middleware cliccando dal menù di avvio “Sblocco PIN”, si apre la finestra di dialogo in cui inserire il PUK.
Questo prima non succedeva.
Anche il cambio PIN del Middleware adesso mostra la finestra di dialogo.
Anche questo prima non succedeva, e mi veniva chiesto di appoggiare la carta al lettore.

Non ho proceduto a cambiare il PIN o a sbloccarlo da Middleware, così da poter essere utile nel testare la procedura da Browser, che, al momento, continua a non funzionare.

Provo utilizzando Firefox, invece di Chrome e vi aggiorno.


(Giovanni Marani) #40

Ho seguito le istruzioni sul manuale:
https://cie30-middleware.readthedocs.io/it/latest/accesso-ad-un-servizio-mediante-il-browser-e-la-cie/firefox.html

…e tutto ha funzionato correttamente!!!
ora provo l’utilizzo e vi aggiorno…

AGGIORNAMENTO
ho effettuato con successo la procedura di richiesta SPID con Lepida utilizzando la CIE come metodo di riconoscimento e come browser FIREFOX!

GRAZIE DAVVERO per l’assistenza e la tempestività di intervento! Uno spettacolo!