Web Analytics Italia

Buongiorno, sul documento pubblicato da AgID all’indirizzo https://www.agid.gov.it/sites/default/files/repository_files/stato_di_attuazione_linee_dazione_-piano_triennale_per_linformatica_nella_pa_2021-_2023.pdf
si può notare che alla pagina 3 AgID sostiene di aver concluso il rilascio della funzionalità che permette di incorporare in un frame parti della dashboard delle statistiche WAI

Rilascio della funzionalità di widget embedding per i siti
PA in relazione alla piattaforma Web Analytics Italia -
(AGID, DTD)
CONCLUSA

Qualcuno sa per caso dove è possibile trovare la funzionalità? Ad oggi vedo solo la possibilità di configurare delle statistiche che arrivano via mail ad intervalli definiti dall’utente ma da nessuna parte del pannello di configurazione WAI si trova la possibilità di reperire il codice del frame che permetta di integrare le statistiche sui siti istituzionali dell’Ente.

Ringrazio anticipatamente per la gentile collaborazione.

Saluti.
Andrea Carraro

ciao

e poi

Andrea

Grazie per la risposta, la mia richiesta però fa riferimento alla possibilità di integrare le statistiche di utilizzo dei siti come viene pubblicizzato per esempio dal sito del Comune di San Gimignano

Statistiche web analytics e opt-out - Comune di San Gimignano

Al momento non trovo questa funzionalità che servirebbe tra l’altro alle PA ad ottemperare ad uno dei nuovi obiettivi del Piano Triennale all’interno del quale AgID chiede espressamente di pubblicare sui siti istituzionali le statistiche.

Per caso hai qualche suggerimento per questo aspetto?

Ciao @andrea.carraro,
nella pagina di dettaglio di ogni sito web trovi una sezione dedicata ai widgets che ti permette di vedere un’anteprima e di ottenere il codice per incorporare le statistiche all’interno del sito web.

3 Mi Piace

Grazie @davide.po io trovo queste possibilità

Ho provato ad esportare in tutti i formati ma nessuna configurazione mi ritorna l’URL da impostare nel frame in modo da generarmi il grafico automaticamente, è come se mancasse una configurazione per esportarlo come widget, cosa che vedo nei parametri nel codice sorgente si San Gimignano.

Ho provato ad aggiungere tra i parametri dell’URL anche “widget=1” come ho visto appunto nel codice dell’Ente inviato in precedenza ma non mi esce quello che vorrei…al massimo ottengo una tabella non formattata.

<iframe style="width: 100%; height: 800px;" src="https://stats.comunesg.it/matomo/index.php?module=Widgetize&amp;action=iframe&amp;containerId=VisitOverviewWithGraph&amp;disableLink=0&amp;widget=1&amp;moduleToWidgetize=CoreHome&amp;actionToWidgetize=renderWidgetContainer&amp;idSite=5&amp;period=day&amp;date=yesterday&amp;disableLink=1&amp;widget=1" frameborder="0" marginwidth="0" marginheight="0" scrolling="yes" data-mce-fragment="1"></iframe>

Hai per caso qualche suggerimento per esportare come widget?

ciao @andrea.carraro ,
noi a San Gimignano abbiamo il doppio tracking. Ho modificato il codice da embeddare nel sito per puntare a due istanza matomo.
Cioe usiamo web analytics italia e una istanza matomo on premise che già utilizzavamo da tempo.
Le statistiche che vedi sul nostro portale le pubblichiamo utilizzando i widget della nostra istanza di matomo.
WAI di agid non penso abbia ancora la possibilità di utilizzare i widget pubblici. Per utilizzarli bisogna abilitare l’accesso anonimo alle viste.

1 Mi Piace

Grazie @perrcla infatti immaginavo che il vostro codice derivasse da Matomo e non WAI.
Ad ogni modo grazie ancora e bravi!
Chissà se avremo mai modo di permettere agli enti di faro lo stesso senza metter su altre istanze parallele per tracciare gli accessi (qui al posto di razionalizzare i data center ci si trova spesso costretti a metter su VM parallele perchè da qualche parte manca sempre un pezzettino).
Settimane fa ho scritto per questo alla mail del supporto WAI ma non ho avuto feedback…speriamo :crossed_fingers:
Ciao!

1 Mi Piace

@andrea.carraro invece sono piacevolmente sorpreso! per curiosità ho spulciato un pò WAI…
Non so se è una funzionalità introdotta di recente, ma anche da WAI di agid è possibile embeddare i widget. Come diceva @davide.po nella pagina di dettaglio del sito c’è la possibilità di copiare il codice dell’iframe, che però funziona solo se utilizzato nello stesso dominio del sito oggetto delle statistiche!

bene così!

1 Mi Piace

Fantastico, non facevo accesso alla pagina di dettaglio, cercavo nella dashboard per quello avevo mandato quegli screen prima!

Molto bene vi ringrazio tutti!!

Ho provato ed effettivamente funziona solamente se sta nello stesso dominio però direi che va più che bene anche così!

2 Mi Piace

Ciao @perrcla , vedo che nella pagina delle statistiche avete inserito la spunta per far scegliere al singolo utente se vuole essere tracciato. WAI è fatto in modo che non si possa risalire in modo specifico all’utente, come fa Google. Come mai questa scelta proposta all’utente? E’ un adempimento richiesto per la privacy?

ciao @lellomaverick.
Quella spunta fa riferimento alla nostra istanza matomo.
Non sono sicuro di quello che dici… nel senso che il cookie di WAI contiene l’ID anonimo dell’utente…
Lo contiene anche il cookie del nostro matomo, ma appunto togliendo la spunta, il cookie dell’ID dell’utente viene cancellato.

Non si tratta di risalire in modo specifico all’utente, ma di tracciare la azioni che compie nel sito.

Scusate nuovamente, ma qualcuno ha notizie che le adesioni a WAI non funzionano regolarmente?
Sto provando a registrare nuove amministrazioni ma una volta letti i dati dall’iPA e cliccato il tasto conferma, non passa alla fase successiva dove sostanzialmente WAI ritorna il codice di monitoraggio.

ma in che stato vedi ora il dominio?

Accedo con SPID di un RTD dell’Ente e lo guido nella prima parte di attivazione, poi una volta confermata l’adesione iniziale con il click al link inviato via mail, vanno inseriti i dati del sito da monitorare

A questo punto il compilatore automatico va a leggere correttamente i dati su iPA come indicato di seguito

Carica un po’ e ritorna in prima battuta un errore di timeout, poi successivamente non parte neanche il caricamento della pagina, si limita a scrivere TUTTO OK sulla destra ma non mi passa alla fase in cui il sito viene messo in attesa e dove puoi reperire il codice di monitoraggio.

Questo mi capita con diversi browser e con accessi fatti con SPID di enti vari.

Volevo capire se altri avevano notato la cosa, anche qui nelle scorse settimane ho fatto in modo che gli RTD scrivessero a WAI ma non c’è risposta.

forse @davide.po può aiutarti…

Ciao @andrea.carraro,
il problema è dovuto a una anomalia di qualche tempo fa che ha causato alcuni disallineamenti.
Adesso dovrebbe essere risolto.

Saluti.

Davide

Grazie @davide.po domani dovrei avere la disponibilità di un RTD per effettuare una prova e in caso ci aggiorniamo.

Intanto grazie ancora!

@davide.po ho provato ora ed il problema è lo stesso…di seguito l’errore

Anche io lo stesso problema da un paio di giorni e non saprei come contattare lo staff che segue WAI

Ciao @andrea.carraro e @franzdav,
se avete già scritto alla casella wai@agid.gov.it vi ricontatterò via mail per approfondire la questione.